Overview:
A user can see call records not owned by the user on Online My Schedule Page. However, the user cannot open the call records from My Schedule Page.
Root Cause:
One possible reason is that the user is added as an attendee in a group call by other users and then this call shows up on the user 's My Schedule page.
Solution:
If the user wants to see the call details, the user should be granted access to the account associated with the group call.
Related Documentation:
CRM Help Documentation: N/A