Overview:
Upon Pushing to CRM from Veeva Align, the following error appears.
Please delete all territory models not created by Align and try again.
Root Cause:
The cause of the issue is that there is another Territory Model in Veeva CRM, next to the VeevaAlign Territory Model.
Solution:
Only one Territory Model can exist in TM 2.0 in the event there is Veeva Align - Veeva CRM integration. All other Territory Models - regardless of their statuses - need to be deleted in Veeva CRM.
Note #1: In the event, there are CRM Managed territories, a second Territory Type needs to be created to differentiate between Align managed territories and CRM Managed Territories existing VeevaAlign Territory Model.
Note #2: TM 2.0 Territory Models are not to be confused with Territory Models of the Modelling Environment in Veeva Align.
Related Documentation:
Align Help Documentation: Align-CRM Integration