Overview:
Upon accessing the Territory Feedback tab on CRM for iPad (Integrated Territory Feedback) and CRM Online (Manager Territory Feedback), the following error occurs:
Feedback Unavailable, Service is currently unavailable. Try Again later.
Root Cause:
The issue may be caused by the following reasons:
- Lack of Model Territory's cache refresh.
- Only particular Model Territories are set in the Feedback (Review) Lifecycle State, not the entire Modeling Project, which remains in draft. Enhanced Feedback (Align Territory Feedback Mode = 2) currently requires the Project and all of its relevant child records (Model Territory and/or MC Cycle) to be in the Feedback (Review) State.
- There are Model Approval Mapping Records whose Model Field Force lookups are not populated.
- The Model Approval Mapping Records are not set up correctly: the Application Role and/or Hierarchy Level values are not correct.
- The Align version is not up to date in the Territory Settings record, due to the lack of the Push to CRM or Import from CRM jobs.
- Outdated Veeva CRM for iPad version.
- (some) Manager Territory does not have any child Territory.
- The manager is included in the Manager and Rep Territory as well.
- The Planned Publish Date and Planned Publish Datetime of the Project is not between (it can be equal to the Start Date as well) the Start and End Date and Datetime of the following object records: Model Roster Member Territory, Model Territory, MC Cycle and its related objects (MCCP, MCCP Targets).
- The Model Territory record does not have any Model Field Force value.
- The MC Cycle for the Project has a clone source for another modeling MC Cycle.
- MCCP Products were loaded to the wrong MCCP Channels.
- The Default Feedback State (default_feedback_state__aln) field is missing from the Project layout and the field value is null.
- The combined number of accounts in the Model and Production territory is more than 30.000.
'Number of Accounts (account number goes here) assigned to Territory Model Id (related model territory id goes here) exceeds maximum 30,000.' error message can be seen in the Google Dev Console. - Veeva CRM (Salesforce): Lightning Web Security for Lightning web components is enabled for the org.
- Veeva CRM (Salesforce): CSP Trusted Site for Align is not set up.
Solution:
- Make sure to run Recalculate Territory Cache on the related Model Field Force after configuration changes.
- Change the lifecycle state of the Modeling Project to Feedback Review, ensuring that all of the relevant child records (Model Territory and/or MC Cycle) are in the Feedback (Review) State.
- Remove the Modeling Approval Mapping Records that are in this state.
In either of the cases, on the Modeling Field Force, run Recalculate Territory Data. - The Application Role and Hierarchy Level values must be correct, according to the related Model Territory records on all Model Territory levels.
- Ensure to run Push to CRM or Import from CRM jobs.
- Ensure to have the latest possible CRM for iPad version.
- The Manager Feedback requires at least one child Territory to be assigned to each Territory the Manager is assigned to.
- Managers cannot provide feedback on MCCPs against their own territory, this information is included here.
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The Planned Publish Date and Planned Publish Datetime of the Project must be between the Start and End Datetime of the related object records mentioned above: Model Roster Member Territory, Model Territory, MC Cycle and its related objects (MCCP, MCCP Targets).
End-dated Model Roster Member Territory needs to checked as well. Records that fall within the Planned Publish Time range. If the related Roster Member is inactive then the related Model Roster Member record must be deleted/modified in way that it is not included in the Feedback.
- All Model Territory records in the Project must have a Model Field Force value.
- This is not supported: https://alignhelp.veeva.com/doc/Content/Align/Targeting/CloneMCCycle.htm
- The mismatches must be solved for every MCCP Channel.
- Add the Default Feedback State (default_feedback_state__aln) field to the Project layout and set the value to "Feedback".
- Possible workaround: Reduce the territory size which also simplifies the CRM sync experience for the rep users: iPad supports a sync of up to 15,000 Account records. Having smaller territories would also simplify things for the rep users so that they always have all their accounts on their iPad.
- This feature must be turned off here: Setup > Session Settings > Lightning Web Security > uncheck "Use Lightning Web Security for Lightning web components and Aura components"
- Make sure that Manager Feedback configured fully in Salesforce CRM: https://alignhelp.veeva.com/doc/Content/Align/TargetingFeedback/CRM/ManagerTerrFeedback.htm
Note:
The data changes made in Align may not instantly reflect in CRM, to display certain changes for Territory Feedback in CRM, users needs to manually refresh the cache for a model field force to immediately make changes available in CRM: Recalculate Territory Data button on the related Model Field Force.
This is recommended whenever a project is already open for feedback and changes are made.
Related Documentation:
Align Help Documentation:
Knowledge base: