Overview:
After setting up the configuration for Engage Connect, this error message appears in the Engage Connect Administrator tab:
Root Cause:
There are two main root causes:
- The environment is a Sandbox Environment, but it points to the Production Engage Connect instance, not the Sandbox Engage Connect instance.
- The Admin user's email address is the same as an HCP account's email address, resulting in a conflict in the system.
Solution:
For Root Cause 1:
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A Sandbox Environment must point to the Sandbox Engage Connect instance. Submit a Support Ticket to have the Engage Connect Server of Veeva Common updated with the Engage Connect Sandbox URL.
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Engage Connect Sandbox URL is https://app-sbx.veevaengage.com
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For Root Cause 2:
- Change the email address of the Admin user to one that has not been used for an existing HCP.
Note: Only HCP emails need to be globally unique. Having reps or admins with the same email should not cause the issue.
Related Documentation:
CRM Help Documentation: Configuring Engage Connect