Overview:
A user tries to access Network Account Search (NAS). After clicking on the New button under My Accounts, instead of NAS, the New Account Wizard is displayed.
Root Cause:
Network and Veeva Settings are configured incorrectly.
User is not set up correctly for Network integration.
Solution:
Please be sure to configure the following:
- Network Setting ACTIVATE NETWORK ACCOUNT SEARCH is enabled. Go to Setup > Custom Settings > Network Settings - click on Manage > activate the Network Setting at the org level or for the user's profile-level settings
- Network Setting Network Customer Master Mode is enabled. Go to Setup > Custom Settings > Network Settings - click on Manage > activate the Network Setting at the org level or for the user's profile-level settings
- If Restrict Access to Custom Settings schema setting is enabled, all users require access to the VeevaSettingsService Apex class in order to access Veeva-delivered custom settings in Salesforce. (Go to Setup > Data Management > Schema Settings > Enable Restrict access to custom settings)
- If Restrict Access to Custom Settings schema setting is enabled: Veeva recommends not using Profile Specific Custom Settings Definition to grant custom settings permissions. If Profile Specific Custom Settings are enabled for a profile, ensure the profile has access to all Veeva-delivered custom setting sets. e.g.
In the above configuration, access is granted directly to Veeva_Settings_vod on the user's profile, in a permission set or in a permission set group. Either remove this custom setting definition or add ALL custom settings definitions to be available to the profile, in the permission set or permission set group.
5. Please set up the user in the following way:
- Country field is populated on the User record
- user is assigned to a Territory
6. Validate Network Credentials and Network Mapping. Go to tab Network Administration > click on Validate for Network Credentials and Network Mappings
Related Documentation: