Overview:
Why is an approved document expired in CRM when a draft version is created in Vault.
Root Cause:
The where clause from the Approved Email Admin has status__v as one of its conditions.
The integration depends on being able to read Draft and Staged documents. If those documents are filtered out by the where clause then the Documents with Approved status are expired unless it's the latest version of the document.
Note: The status__v field should never be used in the user WHERE clause.
Solution:
Remove the status__v field from the Vault WHERE Clause from the Approved Email Administration Tab.
Related Documentation:
CRM Help Documentation: Integrating CRM and Vault for Approved Email