Overview:
After clicking the Unsubscribe button in a received Approved Email, the Unsubscribe Now button on the Unsubscribe page is not working. Pressing the button results in a blank page:
Root Cause:
The Unsubscribe functionality runs using the Veeva Multichannel servers where the Approved Email integration user creates Multichannel Consent records for users that have clicked the Unsubscribe Now button.
If the integration user is unable to read or create Multichannel Consent records, the Unsubscribe Now button does not work and the page does not load.
Solution:
Verify that the Approved Email integration user has Create, Read, Edit, and Delete permissions on the Multichannel Consent object.
Verify that the integration user is not failing any triggers or validation rules on the Multichannel Consent object.
Related Documentation:
CRM Help Documentation: Adding and Customizing Unsubscribe Links
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