Overview:
While attempting to send an Approved Email online, the Add Documents button does not display any Email Fragments for the selection:
However, Email Fragments are available based on the configuration and can be selected Offline.
Root Cause:
This can occur when the APPROVED_EMAIL_FILTER_FIELDS Veeva Message contains non-configurable Approved Document lookup fields as filters.
The APPROVED_EMAIL_FILTER_FIELDS Veeva Message only currently supports the Product_vod__c lookup. No other lookups on the Approved Document can be used as a filter.
Solution:
Navigate to the APPROVED_EMAIL_FILTER_FIELDS Veeva Message and verify that there are no Approved Document lookup fields besides Product_vod__c.
If there are any other lookup fields, do the following:
- Remove the lookup fields.
- Save the changes.
- Clear the Veeva cache.
Related Documentation:
CRM Help Documentation:
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