Overview:
A user creates a new Account and Address using the My Account wizard in Offline CRM, but the Address' primary flag is not auto-updated to TRUE.
However, when creating a new Account and Address in the Online My Account wizard, the Address' primary flag is auto-updated to TRUE.
Root Cause:
The User is missing Edit access to the Primary_vod__c field on the Address object.
Solution:
Grant the User Edit access to the Primary_vod__c field on the Address object.
Related Documentation:
N/A