Overview:
The Address Inheritance job did not copy or create Address data from the Parent Address to the Child Address. The Parent Address meets all entry criteria of the Address Inheritance job.
Root Cause:
There is an inactive Child Address record in the latest batch of the Address Inheritance job which is set as a Primary Address. Inactive Address records cannot be set as a Primary Address. When the Address Inheritance job tries to update it, a trigger error occurs. This interrupts and stops the update process for the entire batch.
Furthermore, due to the update, the Parent Address records of the batch are updated by the job to be added again to the next batch run. This causes the error to occur during the subsequent runs as well.
Solution:
There are three possible solutions to the issue:
- Reduce the Job batch size to 1. This ensures that no other child address is affected by the issue.
- Re-active the affected Child Address record(s).
- Delete the affected Child Address record(s).
Related Documentation:
- CRM Help Documentation: Address Inheritance Support
- CRM Article: Address Inheritance Does Not Create or Update the Address Records in CRM Online