Overview:
User is not able to see the Expand List button on the Sharing Detail page.
Root Cause:
The User object is set to Private Organization-Wide Sharing Default. Due to this non System Administrator, users are not able to see the Expand List button.
Solution:
The Sharing Setting of the User object must be changed to either Public Read Only or Public Read/Write.
Related Documentation:
CRM Article: How to Determine Why a User Has Access to a Record in Salesforce.com (SFDC)?