Overview:
Recipients do not receive emails with Approved Email from Veeva CRM, although the status of the related Sent Email records is Delivered.
Root Cause:
In the event, the status of a Sent Email is Delivered. This means that the recipient's email system accepted the email and sent a successful delivery receipt to the email system of Veeva. This also indicates that the Approved Email and Domain Configuration is correct in Veeva CRM and in Mailgun.
From this point, Veeva cannot track the email. It cannot determine why the recipient server did not actually deliver the email to the mailbox. The issue is related to the network infrastructure or security restrictions deployed at the side of the recipient and is outside of the infrastructure of Veeva and Mailgun.
Solution:
Contact the Local IT Administrator team of the recipient to revise the configuration of the company network and Email Server / Client, including Firewall, Spam Filter settings, and security restrictions.
Related Documentation:
Knowledge Base: