Overview:
Clicking the Send Email button is unresponsive in the Send Email Page in Veeva CRM Online. Another common symptom is that the Send Email UI page looks unusual, containing special characters.
Root Cause:
The issue occurs in the following scenarios:
- The {{insertEmailFragments}} token is present in the Email Template content. However, the value of Email_Allows_Documents_vod__c (Insert Documents) is FALSE.
- The {{insertEmailFragments}} token is not present in the Email Template content. However, the value of Email_Allows_Documents_vod__c (Insert Documents) is TRUE.
These scenarios may occur in the event the Approved Document record or the content is manually edited.
- The behavior may also occur in the event incorrectly. Legacy or non-supported content code is present in the Email Template content code. In most cases, the issue is related to the html tag declarations.
For example, the xmlns attribute is considered legacy and not supported:
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
Solution:
- Be sure that Approved Document is not meeting the first-two scenarios listed in the root cause section.
- It is recommended to try using a simple HTML declaration:
<!DOCTYPE HTML>
<html>
Note: Content development is not within the scope of Veeva Support.
Related Documentation:
CRM Help Documentation: Resources for Creating Approved Email Content