Overview:
When the Language of the user profile is set to Japanese, the report shows no result.
If change the Language to English, there are two records returned in the same report.
Why does the report return no records when the Language is Japanese?
Root Cause:
This is due to the Japanese lifecycle labels using inconsistent translations for the same English base labels.
For almost all filters values, Vault saves the private key and converts them to labels when running a report. Problems occur with Document Status where there are different labels for the same private key. Hence, for Document Status in the report, Vault saves the label of the value in the Vault language, then when running the report Vault converts the Vault language label back to the User language label.
For this report, Vault saves the Binder document status filter CLM承認済 using the English label Approved_CLM as the filter value. However, there are two lifecycle states with the same English label but different Japanese labels: CLM承認済 and 決裁済. So when users run the report, Vault converts "Approved_CLM" into Japanese but since there are two different Japanese labels Vault picks the first one which is 決裁済.
Type | Key | Property | Base Language Label | Translated Label | Language |
lifecycleState | binder_lifecycle_c#approved_c | label | Approved_CLM | CLM 承認済 | ja |
lifecycleState | crm_content_lifecycle_c#approved_c | label | Approved_CLM | 決裁済 | ja |
Solution:
Admins can unify the two different Translated Labels to the same label, or change one of the Base Language labels.
Related Documentation:
Vault Help Documentation: N/A