Overview:
Approved email links and buttons return an error page with a VPN connection: This Site Can’t Be Reached.
Root Cause:
The Approved Email processing is the following:
- The MultiChannel server prepares the emails with the original HTTPS links.
- Mailgun masquerades the links with HTTP prefix for tracking.
- After the emails leave Mailgun, the process is out of Veeva's control.
- When the end-user opens the email with the remote images or clicks on the links, the HTTP requests return to Mailgun where they are translated back to the original HTTPS links.
- If a VPN client blocks HTTP traffic, the masqueraded links do not work as expected (nothing received by Mailgun like in this case).
When the end-user does not use a VPN client, everything works fine (even with Outlook). Nothing blocks HTTP traffic and Mailgun can return the response with the original HTTPS links.
Solution:
This is working as expected, Mailgun has limitations with HTTP masquerade. However, they provide a solution, how to use HTTPS masquerade: How to Enable HTTPS Tracking Links
Related Documentation:
External Mailgun Knowledge Article: