Question:
Is it possible to configure CRM Approved Email to avoid DMARC errors when the Sending Domain and user's Email Domain do not match?
Root Cause:
If the sending domain used for Approved Email and the domain on the From Address of an Approved Email do not match, the email may encounter DMARC authentication issues and be blocked at some recipient domains. Not all email recipient domains check DMARC authentication, but for those that do, differences between the sending and From Address domains can result in deliverability issues.
This can happen if the root domain of the sending domain and the root domain in the From Address are entirely different.
It can also happen if the root domain of both the sending domain and From Address are the same, but the sending domain is a subdomain and the domain's DMARC is set to Strict.
Answer:
It is possible to work around this by changing the From Address field on Approved Emails to read from a custom field instead of the sending user's email address, and building a formula in that custom field that puts together a From Address with a domain that matches the sending domain exactly.
The Reply To address on Approved Emails can remain the user's actual email address, as this does not affect DMARC authentication.
The following configurations outline how to configure CRM and the Email Templates in Vault to avoid DMARC errors:
CRM Configuration
A custom field will need to be created on the User object to store a value that is an email address but with the Domain matching the Sending Domain.
During the creation of this field make sure to copy the Field Name of the newly created field because it will be used during the Vault configuration.
The data type of the field should be "Formula" with a Formula Return Type of "Text":
The formula should be similar to the one below but replace [subdomain] with your Sending Domain which can be found in the Email Domain field in the Approved Email Settings.
FirstName & "-" & "LastName" & "@[subdomain]"
For instance, if there is a user with the First Name of "Test" and the Last Name of "User" and the Sending Domain of "mail.verteobiopharma.com" the formula would be:
FirstName & "-" & "LastName" & "@mail.verteobiopharma.com"
The resulting value would be:
Test-User@mail.verteobiopharma
Ensure that the End Users and Integration User for Approved Email have Read access to this field.
Vault Configuration
In Vault, all Email Templates used by the Org will need to be updated to use the newly created field in CRM for the "From Address".
The token used for this will reference the User object and the newly created API Field Name that was copied in the creation of this field:
{{User.[APIFieldName]}}
For example, if the field name used was Email_Address_Sending_Domain__c the token would be as follows:
{{User.Email_Address_Sending_Domain__c}}
To ensure that users receive responses when a recipient replies to an email, the Reply To Address field will continue to use the token:
{{userEmailAddress}}
With this configuration, all Emails sent will have an email "From Address" that matches the Sending Email Domain to avoid DMARC Issues but also allow for recipients to respond directly to the Sender via their normal Email Address.
Related Documentation:
CRM Help Documentation: