Overview:
Business background:
When an Event has a long life cycle, the status of the Vendor is Eligible when creating the Event. But the Vendor has reached the end date, and the status of the Vendor has been set to inactive before closing the event approval process. If the status of the Vendor is inactive, the end-user submits it for approval and the manager approves it, but the Event History is not created in the Event History section.
Root Cause:
The reason is that the Filter Criteria of the EM_Event_vod. The Vendor_vod field is set as Vendor's status equals Eligible_vod. The Event History is blocked if the status of the Vendor is inactive.
Solution:
Set the Filter Type to Optional instead of Required. This makes that only eligible vendors are selectable through the UI, but there is no database enforcement of the criteria when the event record is updated.
Navigation:
- Log in as System Administrator.
- Click on Setup in the upper-right corner.
- Select Setup --> Create --> Objects --> Event.
- Edit Vendor_vod__c field.
- Change Filter Type to Optional instead of Required in the Lookup Filter section.
Related Documentation:
CRM Help Documentation: Event Vendors