Overview:
The user has defined the Event Action. When submitting the Event for Approval, the Event status is changed to Pending Approval and the next approver also received an email notification and the approval task.
However, the Event Team Member is not created as expected.
Root Cause:
There is no Sharing Setting set for the organizer user, so the organizer does not have access to the approver.
Solution:
- Navigate to: Setup --> Administer --> Security Controls --> Sharing Settings.
- Add Sharing Setting accordingly for the organizer user and be sure the user has access to the approver.
Related Documentation:
CRM Help Documentation: Event Team Members