Overview:
A user receives the following Trigger Error when Tapping Attendee Reconciliation in CRM iRep Events Management:
VOD_EM_ATTENDEE_AFTER_INS_UPD: execution of AfterInsert
System.DmlException: Insert failed. First exception on row 0; first error: DUPLICATE_VALUE, duplicate value found: Mobile_ID_vod__c duplicates value on record with id: [record_id]: []
Trigger.VOD_EM_ATTENDEE_AFTER_INS_UPD: line 111, column 1
Root Cause:
The error occurs because the Walk_In_Status_vod__c is incorrectly set to Needs_Reconciliation_vod on an Event_Attendee_vod__c record corresponding to the EM Event Speaker.
Solution:
This value should be null on the Event_Attendee_vod__c record corresponding to the EM Event Speaker.
The Default for this picklist should be set to --None--:
Related Documentation:
CRM Help Documentation: Walk-in Attendees