Overview:
An error occurs during Submissions Archive import: Internal system error encountered.
Root Cause:
The error message is a generic error noting something unforeseen occurs and requires additional investigation by Veeva.
Solution:
When importing submissions into Submissions Archive there are a few different errors or warnings that can occur. In most instances, Vault provides detailed information about the issues encountered.
However, The error might occur for a few reasons:
- If the error occurs for only some submission imports, this can be caused by a blank required field on the Submissions object record. Edit the Submission records and ensure that all required fields have a value entered.
- If the error occurs for only some submission imports, be sure the Application record that the submission is under is not inactive.
- If the error occurs for ALL submission imports, this can be caused by an unforeseen required field on the Submissions Archive Document Type that does not have a default value. This can be a common occurrence with the Product and Country fields.
- If the error occurs for ALL imports, be sure that the Submissions Archive Document Type is Active. If ALL submission imports are failing, this can occur is the Submissions Archive Document Type is Inactive.
- If the error occurs for ALL imports, be sure there no Reference Constraints on the Applications or Submissions fields that are interfering with Submission imports.
- If the error occurs for ALL imports, be sure that the name__v field on the Submission Metadata (submission_metadata__v) object is not set to be System managed.
A Best Practice is to place required fields with specific Document Types instead of the Base Document Type. This ensures the required fields do not get added to the Submissions Archive Document Type.
Note: The standard system Name__v field is the exception as it cannot be optional.
Documentation:
- Vault Help Documentation: Vault Help