Overview:
The Org is configured to display Out of Territory Child Account records in the Account Hierarchy, but these records are not visible in the Members or Member Of related lists Offline.
Root Cause:
Lookup fields referencing records that are not present on the offline device are included as columns in the Related Lists. In this case, the Parent Account field on the Member Of related list and the Child Account field on the Members related list are both lookup fields that cause records to not display when the referenced record is not present offline.
Solution:
Replacing the Parent_Account_vod__c field in the Member Of related list with the Parent_Name_vod__c field and the Child_Account_vod__c field in the Members related list with the Child_Name_vod__c field allows the Out of Territory records to display in the Related Lists. Since these new fields are text fields containing the name of the associated accounts, they display correctly Offline.
Related Documentation:
CRM Help Documentation: Account Hierarchy