Overview:
When an event is created, the user creating the event is created as a new team member with the default role. But the Record Type of an automatically-created Event Team Member record is Null in CRM Online.
Root Cause:
Even though the user is granted for all Record Types of Event Team Member through Permission Sets, there is still no default record type for Event Team Member on the user's profile.
Solution:
The user needs to specify the default Record Type for Event Team Member on the user's profile when the Event Team Member record is created automatically.
On user's profile page, in the Custom Record Type Settings section, find the Event Team Member object, click Edit button to specify the default Record Type:
Related Documentation:
CRM Help Documentation: Event Team Members
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