Overview:
Lookup filter is not active when using the Manage Attendee button to bulk update Attendees.
Root Cause:
This is working as designed.
Veeva CRM does not have behavior defined and designed for the Manage Attendees bulk page to handle configured filters. As multiple source records can be selected, this would cause conflicts in the filter behavior.
Solution:
In order to use the lookup filter properly, add new and/or update existing Attendee records from the Event record's Attendee related list, where the Attendees can be handled separately as sources of the lookup filter logic.
Note: The lookup filter also does not work if only one single Attendee record is selected on the Manage Attendee page.
Related Documentation:
CRM Online Help: