Overview:
Why are there are duplicate All Accounts Views in CRM Offline?
Root Cause:
The All Accounts view on the iPad represents the formerly, unnamed view that displays all offline accounts. This view can potentially match the name of another All Accounts View that is created Online.
Solution:
To rename the offline view, there is an ALL_ACCOUNTS Veeva Message that can be modified.
To hide the duplicate, the VMobile Object Configuration (VMOC) record for View_vod__c can be customized to filter out the Online version of All Accounts.
- Example where clause: WHERE Name <> 'All Accounts'
- Enable Enhanced Sync needs to be set to True in order to remove the record for existing offline users.
Related Documentation:
CRM Help Documentation: Visibility of Accounts and Territories