Problem:
The user is prompted with the error "<Account Name> has an invalid email address." when sending Approved Email.
Note: If an email is created offline, the Salesforce ID of the account will display instead of the Account Name if the user does not have a VMOC enabled for the Channel Metrics object.
Root Cause:
The email address is listed in the CRM suppression list.
Solution:
Upon receiving the error, Admins should query the Channel_Metrics_vod__c object for the email address in question. Admin can use the below-suggested query:
SELECT Channel_Value_vod__c,CreatedDate,Email_Activity_vod__c,Id,Email_Activity_vod__r.Event_Msg_vod__c FROM Channel_Metrics_vod__c WHERE Channel_Value_vod__c = '<INSERT FAILING EMAIL ADDRESS HERE>'
The error message listed in the Email_Activity_vod__c.Event_Msg_vod__c field indicates why the message failed to send.
Some error messages are self-explanatory. For others, Admins can search for the error message in a search engine to find additional information about the error and ways to resolve the issue.
Some common bounce reasons are detailed below:
DMARC Failure
This is caused by a mismatch in the domain between the user's email address and the Approved Email Domain configured in the Approved Email Settings Custom Setting.
For example, the user sending the email has an email address of joe.user@example.com, however, the Approved Email Domain is set to mail.verteobiopharma.com. This combination will fail DMARC authentication since the domains do not match.
Some recipients may opt to have strict DMARC enforcement which will cause an email sent by joe.user@verteobiopharma.com and Approved Email Domain mail.verteobiopharma.com to fail. The email fails despite the Approved Email Domain being a subdomain of the user's email.
DMARC enforcement is optional. It is up to the recipient's email provider to determine if they will enforce DMARC or not. Servers that do not enforce DMARC may accept emails with mismatched domains.
More information regarding DMARC can be found in the KB article What Does code:550 mean in the Event_Msg_vod field of an Email_Activity_vod of Sent Email in CRM?
User Unknown
The recipient's email server was unable to find the email address at the time and rejected the email. Please check the email address with the recipient and update the address accordingly.
Domain Not Found
Admins should check the recipient email's domain for typos, or that the domain extension is correct. The email is bounced because the domain could not be found.
Not Delivering to Previously Bounced Address
Please check for any previous Channel Metrics records. This error indicates that the email address appears on the Mailgun Suppression list. Admins should check the email address and confirm that it is correct. If the email bounced due to a temporary failure on the recipient's email server, a ticket to Product Support can be opened to have the email removed from the Mailgun Suppression list. Please note, if the root cause of the error is not resolved and the email is removed from the Mailgun Suppression list, the subsequent sent email will also bounce, relist on the suppression list, and potentially damage the reputation of the sending domain.
Resolution of the Error
Once it is determined what caused the email to bounce, Admins should take steps to resolve the issue. If it is determined that the bounce occurred due to a temporary failure on the recipient's mail server, then the Channel Metrics record can be deleted to un-suppress the email address and allow the user to email the address again. Users sending from offline will need to perform a sync on their device to realize the changes made to the Channel Metrics record online.
If there was a typo in the email address, or the email address is otherwise corrected, then no action on the Channel Metrics record is necessary. Users should update the email address on the account.
Reputation Damage
The purpose of a suppression list is to prevent repeated failures to the same email address. If emails are removed from a suppression list without correcting the root cause of the failure, subsequent emails could fail. Repeated failures will cause the reputation of the sending domain to suffer and can result in more emails marked as spam if the reputation of the domain falls too low. The goal of the suppression list is to prevent this from occurring.
Related Documentation:
CRM Help Documentation:
CRM Knowlegebase