Overview:
A user tries to create a record for a child object in a related record layout of the parent object.
The user cannot see the Create button in related object layout. As a result, the user cannot create a new record for the Child Object.
Root Cause:
There are several Root Causes:
- Object-level permission issue in Permission Sets
- The role is set as Read in Parent Object Lifecycle --> Specific State --> Atomic Security: Relationships --> Child Object
- The required field of Child Object is set as Read in Child Object Lifecycle --> Specific State --> Atomic Security: Fields
Solution:
A. If it is an object-level permission issue:
- Navigate to the Admin console.
- Click USERS & GROUPS in the top menu and then click User in the left menu.
- Search the affected username in the list, and check the Security Profile for the user.
- Check the Permission Sets base on the Security Profile.
- Click Object tab and check the Create permission for the Child Object.

B. If there is a Lifecycle for a parent object, check Atomic Security - Relationships.
- Navigate to the Admin console.
- Navigate to Object Lifecycle of the parent object.
- Select a specific state and check Atomic Security - Relationships. Be sure the child object is set as Edit instead of Read in Atomic Security - Relationships.

C. If there is a Lifecycle for a child object, check whether the required field is set as Read only in: Child Object Lifecycle --> specific state --> Atomic Security: Fields.
- Navigate to the Admin console.
- Navigate to Object Lifecycle of child Object.
- Check the Roles section. Be sure the Owner has Edit permission. If there is no Edit permission for the Owner, it means when a user creates a new record, the user cannot input the value for the requested field. So, the system hides the Create button for the user.

- Click the specific state in the Object Lifecycle of the child object.
- Be sure the required field is set as Edit instead of Read in the Atomic Security: Fields section.

Related Documentation:
N/A
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