Overview:
The scheduled Approved Emails are not sent even though the End-User and the Integration User have Field Level Security (FLS) edit permission to the Scheduled_Send_Datetime_vod field on the Sent_Email_vod object.
Root Cause:
The Approved Email Processes are not activated in the Veeva Process Scheduler.
Solution:
Schedule the Approved Email Processes as follows:
- Log in Online with a System Administrator.
- Go to Veeva Process Scheduler.
- Click Edit next to Approved Email Processes.
- Set the desired time interval:
- Click Save.
- When successfully scheduled the process is shown as below:
The Approved Email Process runs an incremental sync from Vault to update the Approved Documents and sends the Sent Email records with Saved_vod and Scheduled_vod status.
Related Documentation:
CRM Help Documentation: