Overview:
From the audit trail of the submission, the submission shows as it is imported.
However, this submission shows there is no content in the Submission Archive Viewer. In addition, it failed to export the submission and gives an error: Server having problems.
Root Cause:
In this issue, the submission record is cloned from another submission record that has
the Submissions Archive Status of IMPORT_SUCCEEDED. But there is no submission imported for this submission since it is created.
Therefore the submission also has a Submissions Archive Status of IMPORT_SUCCEEDED which leads to View and Export actions appearing. Since there is no dossier imported for this submission, the Submission Archive Viewer shows No Items Founds and the export feature does not work.
Solution:
This submission administrator uses a Remove user action to remove the IMPORT_SUCCEEDED status to reflect the correct Submissions Archive Status for this Submission record.
To avoid this issue, a Vault owner can do the following:
- Navigate to: Admin --> Configuration --> Objects --> Submission --> Fields.
- Click on the Submissions Archive Status field.
- Select the option Do not copy this field in Copy Record.
- Save the changes.
Related Documentation:
N/A