Overview:
When an HCP completes and submits an Event Survey, a Survey Target is not created in CRM.
Root Cause:
The Survey Admin is missing FLS Edit permission to one or more fields on the Survey_Target_vod object.
When using Event Surveys, Survey Targets are created by the Survey Admin after a response has been submitted. Because of this, the Survey Admin must have FLS Edit access to all fields on the Survey_Target_vod object that are populated on the Event Survey.
For example, if Detail_Group_vod, a lookup to Product_vod, is populated on the Event Survey, the Survey Admin requires FLS Edit access to both the Detail_Group_vod and Product_vod fields on the Survey_Target_vod object.
Solution:
- Check the Survey iFrame Alerts section of the Survey Administration tab for any errors:
- Grant the Survey Admin FLS Edit permission to the field listed in the error.
- Clear the Veeva cache.
Note: Only one error is listed at a time. If the missing permission is granted and a Survey Target is still not created, check the Survey Administration tab again to confirm that no additional errors have occurred.
Related Documentation:
CRM Help Documentation: