Overview:
When publishing an HTML Report in CRM Online, the status is stuck as In Progress.
Root Cause:
One reason is that the user is missing Edit Field-Level Security (FLS) on the Failure_Msg_vod field of the HTML_Report_vod object.
Solution:
Grant the user with Edit FLS on the Failure_Msg_vod field of the HTML_Report_vod object and then publish again.
Please refer to this guide of FLS if needed: Field-Level Security
Related Documentation:
CRM Help Documentation: N/A