Overview:
A user needs to modify an Account through a Data Change Request (DCR). After trying to apply changes, the DCR page either freezes or the user receives the error message: Error: Invalid Data. Review all error messages below to correct your data.
However, the error message does not specify which field contains the invalid data.
Root Cause:
A field set as DCR Required in the DCR Field Types object is not added to the Page Layout.
Solution:
All fields set as DCR Required need to be added to the relevant Account Page Layout.
Related Documentation:
CRM Help Documentation: Configuration of DCR Controlled Fields