Overview:
The child account Data Change Request (DCR) cannot be created due to an error: A system error has occurred and Veeva Systems has been notified. Please try again.
Root Cause:
Check two settings:
- The parent account has Customer_Master_Status_vod__c = Rejected_vod
- The child account has Customer_Master_Status_vod__c = Rejected_vod
The text of the Error message is taken from Veeva.Message ENDPOINT_NOT_VALID. Description for this Veeva.Message: Error message used by trigger for when a child account record is data loaded, but either the child or parent account has a status of Under Review or Rejected.
The Error Message is generated in the VOD_SHADOW_ACCOUNT Apex class using the rejectInvalidAccounts function during Accounts testing in the Child_Account_Before_UPDINS trigger.
Solution:
Be sure both the parent account and the child account have Customer_Master_Status_vod__c = Valid.
Related Documentation:
N/A
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