Overview:
A user sets a VMobile Object Configuration (VMOC) record per Profile for a specific object. Even with Active_vod = True, no records are downloaded.
Root Cause:
This is caused by the Profile_ID_vod (Label Profile) which is populated with a 15-digit Salesforce ID instead of an 18-digit ID. This usually occurs when records are created in Bulk mode.
The VMOC record without the Profile_ID_vod would work as an Organization-wide VMOC record if Active. Otherwise, no records are downloaded at all if the Profile_ID_vod is filled with a 15-digit Salesforce ID.
Solution:
Go to the affected record. Click on Edit --> Select the Profile --> Save. The 18-digit ID is populated as the Profile_ID_vod is in the drop-down Profile list.
Related Documentation:
CRM Help Documentation: Using VMobile Object Configurations