Overview:
Private alerts which are setup for some users or profiles are appearing for all users.
Root Cause:
In addition to configurations outlined in the guide, private or non-public alerts are controlled by the Public_vod__c flag on the Alert_vod__c object and the where clause on the VMobile Object Configuration (VMOC) for the Alert_vod__c, Alert_User_Action_vod__c, and Alert_Profile_vod__c objects.
Solution:
The where clause on the VMOCs listed above is set correctly out-of-the-box however, some orgs can be deployed with an incorrect VMOC where clause.
Be sure the where clauses are correct for each VMOC:
- Alert_vod__c: Where Activation_Date_vod__c <= TODAY AND Expiration_Date_vod__c > TODAY AND Public_vod__c = TRUE
- Alert_User_Action_vod__c: WHERE Alert_vod__r.Activation_Date_vod__c <= TODAY AND Alert_vod__r.Expiration_Date_vod__c > TODAY AND User_vod__c = @@VOD_SF_USER_ID@@
- Alert_Profile_vod__c: WHERE Alert_vod__r.Activation_Date_vod__c <= TODAY AND Alert_vod__r.Expiration_Date_vod__c > TODAY AND Alert_vod__r.Public_vod__c = FALSE AND Profile_vod__c = @@VOD_SF_PROFILEID@@
Related Documentation:
CRM Help Documentation: CRM Mobile Application Home Page