Overview:
The Last Update time on the left bottom screen of iRep didn't change after a successful sync. There is no error appearing in the Error tab. When checking the user Activity log, it contains "unexpected token" sync warnings.
Root Cause:
The sync warning prevents the iRep Last Update time from being updated. It might come from the where clause in VMobile Object Configuration (VMOC).
Since incremental sync appends "AND SystemModstamp > ..." to the query, make sure the entire WHERE Clause is included in parenthesis if it contains the OR logical connector.
Example: When using Product Metrics for Child Accounts feature, the WHERE clause of the Product_Metric_vod VMOC needs to be changed. The parenthesis is required for the entire WHERE Clause.
- The default is: WHERE Account_vod__r.Name != null
- Change to: WHERE (Account_vod__r.Name != null or Location_Child_vod__r.Name !=null)
Solution:
Check the VMOC WHERE clause of the warning object. If it contains the OR logical connector, add parenthesis to the entire WHERE clause.
Related Documentation:
CRM Help Documentation: Product Metrics for Child Accounts