Overview:
The Call is created Online with several attendees. After updated and submitted Offline, some of the Child Calls have different values in a custom field from the Parent Call.
Root Cause:
The Child Calls are not downloaded to Offline.
The user updates the custom field value Offline and uploads through submitting. Only the Calls that are downloaded to Offline get the custom field updated.
Solution:
Check the VMobile Object Configuration (VMOC) of the Call and be sure the where clause includes all the Parent and Child Calls.
Related Documentation:
CRM Help Documentation: Using Special WHERE clauses for VMOCs