Overview:
When querying objects using Workbench or a similar tool using a where clause from a Vmobile Object Configuration (VMOC), the result is slightly higher than the Record count on the Offline database under Settings within the Mobile CRM app.
Root Cause:
During sync, the query on the VMOC is slightly modified in order to leave out bad records.
Example:
- VMOC Call2_vod__c is configured with a where clause: SELECT Id FROM Call2_vod__c WHERE (Call_Date_vod__c>=LAST_N_DAYS:180)
- The sync process changes the query to:
- SELECT Id FROM Call2_vod__c WHERE (Call_Date_vod__c>=LAST_N_DAYS:180) AND (Account_vod__c IN (SELECT Id FROM Account))
- SELECT Id FROM Call2_vod__c WHERE (Call_Date_vod__c>=LAST_N_DAYS:180) AND (Medical_Event_vod__c IN (SELECT Id FROM Medical_Event_vod__c))
3. This results with Calls being left out which do not have an Account or a Medical Event id populated.
Solution:
This is working as designed.
Related Documentation:
CRM Help Documentation: N/A
Send us your feedback: We're always looking for advice to help improve our Knowledge Base! Please let us know if this article was helpful or provide feedback on how we can improve your experience here.
Thank you