Overview:
The My Tasks tab is being used in Veeva CRM for iPad. When trying to sync, the following error is displaying in the user activity logs:
Didn't understand relationship 'Tasks' in FROM part of query call. If you are attempting to use a custom relationship, be sure to append the '__r' after the custom relationship name. Please reference your WSDL or the describe call for the appropriate names.
On an initial sync or database refresh, the sync fails.
Root Cause:
The error is caused when the user does not have access to the Related To field on the Tasks standard object. The Call2_vod__c object requires access to this field.
Solution:
To correct the error, do the following:
- Assign the user access to the Related To field on the Tasks standard object.
- Clear the Veeva cache.
- Sync the user's iPad.
Related Documentation:
CRM Online Help: CRM Mobile Application Home Page