Overview:
The CRM Camera app opens on iPad, but displays a black screen. In addition, the Camera app opens without access to the Camera Roll.
Root Cause:
The Veeva CRM app is not granted permission to use the Camera or access Photos.
Solution:
If the user sees a black screen, Veeva CRM can be granted permission to use the Camera app by completing the following steps:
- Navigate to: Settings --> Privacy --> Camera.
- Tap the button next to Veeva CRM.
If the Camera opens but does not allow access to saved Photos, update the permissions to Photos for the Veeva CRM app using the following steps:
- Navigate to: Settings --> Privacy --> Photos.
- Click Veeva CRM in the list of apps and change Allow Photos Access to All Photos.
Related Documentation:
CRM Help Documentation: Managing Documents and Attachments Offline