Problem:
When enabling Advanced Text Search, the following error appears in the failed logs under the Content Search Process History section on the CLM Admin Tab:
VeevaContentDocumentLinkTrigger: System.LimitException: Too many SOQL queries: 101
Root Cause:
In Salesforce, the following error appears when you exceed the Execution Governors Limit (you can run up to a total 100 SOQL queries in a single call or context). It is an overall system limitation. The content notes job will run successfully as long as the total number of queries run by the content notes job and other triggers, jobs, and workflows running at the same time does not exceed 100.
The ContentNote Batch Size and the ContentDocument Batch Size are Multichannel Settings that are used internally if the Salesforce API limits are hit when generating ContentNotes while enabling CLM Advanced Text Search on an org.
Solution:
These settings are found at Setup -> Custom Settings -> Multichannel Settings.
Customers are not supposed to change those settings unless it is determined that they need to do so. Reducing the ContentNote Batch Size will only improve the chance of not exceeding this limit.
Related Documentation:
CRM Help Documentation:
Salesforce Help Article: