Overview:
When CLM Content is viewed during a Call, the CLM Key Messages are not being created and tracked in the zvod_CLMDetails section.
Root Cause:
The user is configured to use the CLM Consent Capture functionality. This is governed by the Account.CLM_Opt_Type_vod field or the CLM Explicit Opt In Multichannel Setting Custom Setting.
- If Account.CLM_Opt_Type_vod = 'Never_vod', then Account can never be opted-in.
- If Account.CLM_Opt_Type_vod = 'Implicit_Opt_In_vod', then use the implicit opt-in model type
- If Account.CLM_Opt_Type_vod = 'Explicit_Opt_In_vod', then use the explicit opt-in model type
- Account is opted out unless you see an Opt In Multichannel Consent record
- If Account.CLM_Opt_Type_vod = NULL or the user does not have Field Level Security (FLS) to the field, then look at the CLM Explicit Opt In Multichannel Setting Custom Setting
- If CLM_EXPLICIT_OPT_IN_vod is set to false, then the Account is implicitly opted in.
- If CLM_EXPLICIT_OPT_IN_vod is set to true, then the Account is required to have an Opt in Multichannel Consent record.
Solution:
To track the CLM Key Messages, perform one of following:
- Disable the CLM Explicit Opt In Multichannel Setting Custom Setting
- Set the Account.CLM_Opt_Type_vod to Implicit_Opt_In_vod.
- Ensure the Account has an Opt in Multichannel Consent record for the CLM_vod record type.
Related Documentation:
CRM Help Documentation: MC Settings
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