Overview:
The product has been assigned through admin user's My Setup but it does not display in the user's My Setup page in CRM
Root Cause:
The user does not have access to the product.
Solution:
Be sure the user has access to the product.
One method is to adjust the Sharing Settings. Navigate to Setup --> Administration Setup --> Security Controls --> Sharing Settings, select Product Catalog, and then adjust the Sharing Settings accordingly.
Please refer to this guide if needed: Create Sharing Rules
Related Documentation:
CRM Help Documentation: My Setup Products