Overview:
A product or driver is not displaying on the Suggestions Insight panel in CRM online, even though a suggestion tag has been created.
Root Cause:
There are more than four total product or driver tags on that specific record type.
Solution:
This is expected behavior.
When viewing insights on the suggestion page, there is a maximum of four rows per group. The three tags with the largest number of suggestions will appear first, and the fourth row is labeled "Other". The "Other" category is comprised of all other tags.
When there are four or fewer total tags in the group, the "Other" category will not display.
Related Documentation: