Overview:
When viewing the details of an Account on Veeva CRM for iPad, users are seeing Territory Specific Field (TSF_vod) values for the Account, but they are for a Territory other than one the user is themselves assigned to.
Root Cause:
This can occur if the user does not have proper access to VMobile Object Configurations (VMOCs) for the Territory2 and UserTerritory2Association objects.
Users must be able to sync down the Territory2 and UserTerritory2Association records relevant to their assigned Territories for the Territory Specific Field records on Account Details to filter properly to their assigned Territories.
Solution:
Verify that the VMOCs for Territory2 and UserTerritory2Association are Active for the User's Profile, and that the WHERE clause on the VMOC is not excluding required records from the user.
Additionally, verify that the user can actually access the relevant VMOCs. If controlling access to VMOCs by Sharing Settings, verify that the user is not prevented from accessing the appropriate VMOCs due to Sharing Rules on the VMobile_Object_Configuration_vod object.
Related Documentation:
CRM Help Documentation: Using VMobile Object Configurations