Overview:
The Product Metrics record displays properly in CRM Online but it does not display on CRM iPad.
Root Cause:
The Metric Configuration record has a value on the Detail_Group_vod__c field for the Product Metrics that is displayed on the Account record. But the user does not have FLS (Field-Level Security) on the Detail_Group_vod__c field of Product_Metrics_vod__c object.
Solution:
Grant user Edit access on the Detail_Group_vod__c field of Product_Metrics_vod__c object.
Please refer to this guide if needed: Field-Level Security
Related Documentation:
CRM Help Documentation: N/A