Overview:
When Clicking on CRM View User Territory Button, a user receives Error: Attempt to de-reference a null object.
Root Cause:
No visibility to the User object.
Solution:
In order to use the View User Territory button, the user needs access to the User object. Be sure that:
- The user has the required Field Level Security (FLS) on the User object.
- The user has access through the Sharing model (if user is set to Private).
Related Documentation: