Overview:
Child Account records are automatically marked as Primary when updated.
Root Cause:
Veeva has functionality that can automatically set Child Account records as Primary when the record is edited. The Veeva Setting Enable Simple Hierarchy is designed to be used when each Account has only one associated Child Account. This feature automatically sets Child Account records as Primary upon Save.
Solution:
Disable the Custom Veeva Setting Enable Simple Hierarchy.
- Navigate to Setup --> Develop --> Custom Settings --> Veeva Settings --> Manage.
- Click Edit.
- Disable (Uncheck) Enable Simple Hierarchy.
- Click Save.
- Clear the Veeva cache.
Related Documentation:
CRM Help Documentation:
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