Overview:
When reps add unverified accounts to CRM on the offline device and then perform a sync, the Account is removed.
Root Cause:
When a rep creates an Unverified Account, it generates a Data Change Request (DCR) and the DCR creates a DCR Line record. The data captured from the fields listed below are always added to the DCR Line record if one of the two conditions exist:
1. The field is on the Page Layout and that field has a value provided by the rep.
2. The field has a default value set by the system at the Record Type level.
Solution:
Ensure that the rep has Read Field Level Security (FLS) to the four fields listed below:
Account
- IsPersonAccount
- Territory_vod__c
- RecordTypeID
Address
- RecordTypeID
Related Documentation:
CRM Help Documentation: iPad DCR Process