Overview:
A user is attempting to create a new Account and Creating Unverified Records is configured for the user. After the the user clicks the Save button, instead of the user being directed to the newly created account detail page, the user is directed to the My Accounts page.
Root Cause:
A possible cause of this issue is the user has Read/Edit Field Level Security (FLS) to the Network_Create_Unverified_vod field on the Data_Change_Request_vod object yet the NETWORK_UNVERIFIED_ACCOUNT_TYPES_vod Network Setting is not populated with the Developer Name of the account record types and countries for accounts that can be created as unverified.
Solution:
Remove Read/Edit FLS on the Network_Create_Unverified_vod field on the Data_Change_Request_vod object for the user and clear Veeva Cache.
Related Documentation:
CRM Help Documentation: Creating Unverified Records