Overview:
When adding Survey Targets to a Survey, the targets appear as they are being added. After they are selected, they are grayed out and the number is updated on the Add Selected button located on the pop-up target list. When clicking Add Selected, no targets are added to the list.
When answering questions for existing targets, an error appears: Failed to save survey target.
Root Cause:
The Channels_vod field on the Survey_vod and Survey_Target_vod objects appears as a Picklist type within the UI when selecting the values at the point of Survey and Survey Target creation. The field type has to be of type Text(255) and not a picklist. The Veeva interface builds something that appears as a Picklist at the time of page access.
Solution:
The Veeva (VOD) field types should not be changed. Be sure that Channels_vod field on the Survey_vod and Survey_Target_vod objects are set to a Text(255) field type.
Related Documentation:
CRM Help Documentation: N/A
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